Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
Geode Packages
Manage
Activity
Members
Labels
Plan
Issues
0
Issue boards
Milestones
Wiki
Code
Merge requests
0
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Projet GEODE
Geode Packages
Commits
ea3d80e0
Commit
ea3d80e0
authored
2 years ago
by
Alice Brenon
Browse files
Options
Downloads
Patches
Plain Diff
Apply some guix automatic styling
parent
d797a0d0
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
geode/packages/encoding.scm
+49
-33
49 additions, 33 deletions
geode/packages/encoding.scm
with
49 additions
and
33 deletions
geode/packages/encoding.scm
+
49
−
33
View file @
ea3d80e0
(
define-module
(
geode
packages
encoding
)
#
:use-module
((
gnu
packages
compression
)
#
:select
(
unzip
zip
))
#
:use-module
((
gnu
packages
haskell-xyz
)
#
:select
(
ghc-attoparsec
ghc-edit-distance
ghc-optparse-applicative
ghc-pipes
ghc-xml
))
#
:use-module
((
guix
build-system
gnu
)
#
:select
(
gnu-build-system
))
#
:use-module
((
guix
build-system
haskell
)
#
:select
(
hackage-uri
haskell-build-system
))
#
:use-module
((
guix
download
)
#
:select
(
url-fetch
))
#
:use-module
((
guix
git-download
)
#
:select
(
git-fetch
git-reference
))
#
:use-module
((
guix
licenses
)
#
:select
(
bsd-3
))
#
:use-module
((
guix
packages
)
#
:select
(
package
origin
base32
)))
#
:use-module
((
gnu
packages
compression
)
#
:select
(
unzip
zip
))
#
:use-module
((
gnu
packages
haskell-xyz
)
#
:select
(
ghc-attoparsec
ghc-edit-distance
ghc-optparse-applicative
ghc-pipes
ghc-xml
))
#
:use-module
((
guix
build-system
gnu
)
#
:select
(
gnu-build-system
))
#
:use-module
((
guix
build-system
haskell
)
#
:select
(
hackage-uri
haskell-build-system
))
#
:use-module
((
guix
download
)
#
:select
(
url-fetch
))
#
:use-module
((
guix
git-download
)
#
:select
(
git-fetch
git-reference
))
#
:use-module
((
guix
licenses
)
#
:select
(
bsd-3
))
#
:use-module
((
guix
packages
)
#
:select
(
package
origin
base32
)))
(
define-public
ghc-html5-entity
(
package
...
...
@@ -27,10 +36,10 @@
(
synopsis
"A library for looking up and validating HTML5 entities."
)
(
description
"This package provides a library for looking up and validating HTML5 entities.
The <http://html.spec.whatwg.org/multipage/entities.json following> document is
used as an authoritative source of the valid entity names and their
corresponding
codepoints. You can think of this library as about bindings to
the data from that file. For usage see the Text.Html5.Entity module."
)
The <http://html.spec.whatwg.org/multipage/entities.json following> document is
used as an authoritative source of the valid entity names and their
corresponding
codepoints. You can think of this library as about bindings to
the data from that file. For usage see the Text.Html5.Entity module."
)
(
license
bsd-3
)))
(
define-public
ghc-xmlfilter
...
...
@@ -40,17 +49,19 @@
(
home-page
"https://gitlab.huma-num.fr/alicebrenon/XMLFilter"
)
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
sha256
(
base32
"1prsrhpzqx7wcbvzvmc4845f03bvxfazn3v2kfajnr1fnrcbb8nf"
))))
(
base32
"1prsrhpzqx7wcbvzvmc4845f03bvxfazn3v2kfajnr1fnrcbb8nf"
))))
(
build-system
haskell-build-system
)
(
inputs
(
list
ghc-attoparsec
))
(
synopsis
"SAX-based library to handle XML-like documents"
)
(
description
"Reads the files as streams of markup events to allow altering the file
content on the fly and fixing broken files which aren't proper XML"
)
(
license
bsd-3
)))
"Reads the files as streams of markup events to allow altering the file
content on the fly and fixing broken files which aren't proper XML"
)
(
license
bsd-3
)))
(
define-public
processing-lge
(
package
...
...
@@ -59,20 +70,22 @@
(
home-page
"https://gitlab.huma-num.fr/disco-lge/processinglge"
)
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
sha256
(
base32
"0hzlcwy2zdzgy5a2il19zk24159lwpgnbv4cqbi8jpxv5jwb0sww"
))))
(
base32
"0hzlcwy2zdzgy5a2il19zk24159lwpgnbv4cqbi8jpxv5jwb0sww"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
(
delete
'check
))))
'
(
#
:phases
(
modify-phases
%standard-phases
(
delete
'check
))))
(
propagated-inputs
(
list
soprano
unzip
zip
))
(
synopsis
"Scripts and data for project DISCO"
)
(
description
"Scripts to process La Grande Encyclopédie and suggestions of filters to
clean the ALTO files."
)
(
license
bsd-3
)))
"Scripts to process La Grande Encyclopédie and suggestions of filters to
clean the ALTO files."
)
(
license
bsd-3
)))
(
define-public
soprano
(
package
...
...
@@ -81,9 +94,12 @@
(
home-page
"https://gitlab.huma-num.fr/disco-lge/soprano"
)
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
uri
(
git-reference
(
url
home-page
)
(
commit
version
)))
(
sha256
(
base32
"17njp16nn2lf7xldkdbkhm7p7vji61pmli3fsdbk9azys1k2yhvy"
))))
(
base32
"17njp16nn2lf7xldkdbkhm7p7vji61pmli3fsdbk9azys1k2yhvy"
))))
(
build-system
haskell-build-system
)
(
inputs
(
list
ghc-edit-distance
ghc-pipes
ghc-roman-numerals
ghc-xml
ghc-optparse-applicative
))
...
...
@@ -91,7 +107,7 @@
(
description
"Soprano is a tool developed for project GÉODE
(@xref{https://geode-project.github.io/}) which studies the geographic discourse
in encyclopedias. It was desiged to extract encyclopedia articles from OCRed
in encyclopedias.
It was desiged to extract encyclopedia articles from OCRed
pages represented by a set of ALTO files.
It lets one apply various filtering in the process, for instance specifying the
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment